Evoque Owners Club banner

1 - 12 of 12 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Have a Prestige on order 1st Sept ,After reading the forum and all the problems with the car I am beginning to think I have bought a lemon.
 

·
Registered
Joined
·
63 Posts
what problems?
 

·
Registered
Joined
·
11 Posts
There are about 5 or 6 individual problems and a couple experienced by more than one person. All of that on a forum designed to discuss a specific car. Hardly adds up to a lemon does it?
 

·
Registered
Joined
·
186 Posts
I understand your concerns, as I sometimes have a minor wobble, but to put things in perspective, most posts are entirely positive about the car.


I am fairly confident that if you were to read posts about other cars, be they Mercedes, BMW or Ford et al, problems would be posted. The majority of car owners of any marque experience no issues whatsover, and that can be said about the RRE. At the end of the day, if you are one of the unlucky ones with difficulties, the car would be under warranty.



I would stick with it. If you cancel now, you may regret it.
 

·
Registered
Joined
·
13 Posts
We've been without ours now for 11 days.....and don't know when we are going to be getting it back. Our dealer can't even tell us what the problem is!! Thankfully, I made a short video on my phone of the problem which they have now sent to Land Rover HQ. Can't believe that we waited so long to get it & now its standingat the garage.....frustrating is an understatment.
 

·
Registered
Joined
·
74 Posts
I've had mine since September and love every drive that we have together!! Sadly, my only negative experience has been people 'looking/photgraphing/videoing' without my consent (rant elsewhere on the forum!!) but really having moved from 2 X BMW and 1 X XKR to this + hubbies X5 has been a pleasure.....please wait no matter how frustrating it becomes!
 

·
Registered
Joined
·
13 Posts
When its left unlocked for a while it goes totally dead. Theres no electrics, you can't start it or even lock it. Then after about 3 or 4 hours its fine again. Its been to LR twice now but as yet there unsure why its doing it. Very strange!!
 

·
Registered
Joined
·
27 Posts
Discussion Starter #9
Yes there seems to be lots of problems with the car, On another forum somebody else has your problem. This does not fill me with confidence that R.Rover can sort it out,I was an electronics engineer and an intermittent fault is the hardest to diagnose.
 

·
Registered
Joined
·
2 Posts
Hi all,

I have had my RRE since October.
It's a great car with my only reservation being the fuel consumption.


I have had a couple ofelectricalquirks


1.
Car won't start sometimes and says that "smart key cannot be found".
I have to lock the car andunlockit again with the smart key to rectify.


2.
Car said "gear box fault" when I selected reverse and would not engage.
Had to select and deselect several times before it corrected.


3.
Blue tooth seems a littletemperamental.


Still love it.
 

·
Registered
Joined
·
21 Posts
I think we shouldn't expect a faultless car tho. Mine has rattle on driver side door panel. Other than that, it runs fine after a month. Most of my current cars or previous cars have some minor problems. My Aston Rapide, C63, E63 all have rattle and minor electrical problems but dealers were able to fix it. The worst is California but dealer changed the whole gearbox(under warranty) and i still love it. RRE is a bit overpriced if you only look at its spec but it worths every penny if you look at it as a whole package ieits design, brand....


If i were you, i would wait.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #12
Most of the faults appear to be electrical I suspect computor problems, The car is reliant on softwear to run it. Hopefully these can be cured by updates,Best to buy a car when it's been in production for a year and hopefully any problems have been ironed out.
 
1 - 12 of 12 Posts
Top