Evoque Owners Club banner

21 - 36 of 36 Posts

·
Registered
Joined
·
1,851 Posts
I agree with Donna, JLR are replacing the steering rack etc. On a fix on fault basis, assuming that it was the bolts that sheared/failed. Look on this forum for steering rack problems/failure for more info.
 

·
Registered
Joined
·
1,741 Posts
What is limp mode?...it is the biggest load of 'horse poo' ever thought up....In the old days cars either worked, sort of worked or just broke down at the side of the road. Now we have this rubbish, where to protect an engine you can hardly get up a hill, putting the foot down does nothing, and is real scary trying to drive in limp mode.

I personally would break the guys leg that thought it up, and let him limp home :ROFLMAO:
(rant over)
 

·
Registered
Joined
·
1,851 Posts
I collected mine from dealership yesterday after having some work done. when I got home I restarted & it was in "Restricted Performance" mode & an EML light was on, it would not rev over 2,800 so I shut down & left it. Went out this morning --- No warnings or symbols. This must be the Magic of JLR at work overnight. :unsure: ;):unsure:
 

·
Registered
Joined
·
9,456 Posts
LOL, The Land Rover fairies came out in the night and tinkered!!!!
 

·
Registered
Joined
·
1,851 Posts
Perhaps they should work all day - every day as well (y) :sneaky:
 

·
Registered
Joined
·
9,456 Posts
That would work methinks..
 

·
Registered
Joined
·
31 Posts
Often it's a temporary glitch - a sensor malfunctioning. I had it once on my FL2 SD4 and a couple of days ago on the Evoque. On both occasions restarting the engine cured it. Hasn't come back (yet) on the Evoque.
 

·
Registered
Joined
·
9,456 Posts
You are of course right. As cars become more electronic and full of wizardry there are bound to be the odd hiccup-annoying as it is though.
 

·
Registered
Joined
·
9,456 Posts
Thats correct, Just ask veteran or Mrs V, I did-not a good reply-described him as "looking like the last turkey in the shop!!!"
 

·
Registered
Joined
·
1,851 Posts
Odd hiccup, Maffy are you sure you are talking about a JLR product. ❓ ❓ ❓
 

·
Registered
Joined
·
9,456 Posts
Yes Bazz, Veteran drives a Jag, has this issue so is related to the topic and JLR range.
 

·
Registered
Joined
·
1,851 Posts
Drove mine today, when I started first time I had the red triangle warning symbol which stayed on until I got home 4 starts later. :mad: :poop:
 

·
Registered
Joined
·
1,741 Posts
Modern electronic in cars are hellish, limp mode being a prime example, but my Wifes car, a Smart Fortwo has the weirdest fault, that it is not worth telling the dealer, in case he has to strip the whole dash down, just for a car clock. Fault...The dash display car clock changes to a random different time if the outside temperature is freezing overnight, but from spring to autumn it runs fine ...Crazy, no idea why it is temperature dependant, as its just a stupid car clock LOL (luckily there is another clock in the cars radio, and that remains correct)
 

·
Registered
Joined
·
185 Posts
I had a clock in a Mini that was always exactly the correct time, twice a day. 🤔
 
21 - 36 of 36 Posts
Top