Evoque Owners Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Does anyone know about the Haldex pumps? I'm really rather pissed now as I've owned my car for 3 years and have practically rebuilt it in that time. I was in the process of looking at the new evoque when I've just been hit with another bill of £1500 for a warning message related, they claim to a faulty Haldex pump.

I've read previously JLR don't specify maintenance on these pumps so I'm rather angry that I've to fork out for a faulty one outside of warranty.

Not even sure it will cure this daft message.

Gutted.

2.2 SD4 Dynamic Black
 

·
Registered
MY15 2.2L
Joined
·
2,873 Posts
Welcome the the forum.
Always nice to start with an "Hello" etc., and people on the 'owners forum' always like to see photos of new people's Evoques :)

Lots of previous Haldex chat:
 

·
Registered
MY16 HSE Dynamic LUX, Volvo 850R
Joined
·
2,394 Posts
The dealer has probably already done this unless they are 100% certain its the haldex but its worth plugging a diagnostic into it to see if theres any codes stored, it could be something as simple as an ABS sensor, the drivers rear seems to be the most common

PS - Your running a 6yr old LR at least without warranty, braver man than me
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
The dealer has probably already done this unless they are 100% certain its the haldex but its worth plugging a diagnostic into it to see if theres any codes stored, it could be something as simple as an ABS sensor, the drivers rear seems to be the most common

PS - Your running a 6yr old LR at least without warranty, braver man than me
I paid for the diagnostic but just not sure how confident I am in what’s being said. I see a lot of Disco owners have this issue too. Some people have had the full replacement & still get the warning light. I just can’t believe how bad the build quality is for cars this price 🙈
 

·
Registered
Joined
·
85 Posts
I feel your pain - mine was fine until it went in for a rear diff service and since then it's not been right. The Haldex pump has been replaced but the transmission still has an issue on it. There seems to be some sort of traction problem when driving away from stand-still. Still trying to get it back in to be looked at again. Luckily I had taken out an RAC extended warranty when I got the car in October last year. (Mines a 2013 plate).
 

·
Registered
Dynamic 3 door, 2013, SD4, santorini black with pimento and ebony
Joined
·
520 Posts
Are they sure it is the pump or the software?
Reason I am asking I had a problem with my XC90 which runs the same Haldex set up. Turned out the software had corrupted and cost about £100 to fix. Bad news was it went again within 2 years and the control unit had failed totally which was a £1200 part, but just one hour to fit.
Am really surprised by the numbers of Haldex pump failures on JLR. They are a standard 4wd product used by many manufacturers across the world, my brother and I have both run them over 200 000 miles each and they have never even had an oil change.
Weird that so many pumps go on Evoques unless the dealers are just replacing everything for any fault?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Are they sure it is the pump or the software?
Reason I am asking I had a problem with my XC90 which runs the same Haldex set up. Turned out the software had corrupted and cost about £100 to fix. Bad news was it went again within 2 years and the control unit had failed totally which was a £1200 part, but just one hour to fit.
Am really surprised by the numbers of Haldex pump failures on JLR. They are a standard 4wd product used by many manufacturers across the world, my brother and I have both run them over 200 000 miles each and they have never even had an oil change.
Weird that so many pumps go on Evoques unless the dealers are just replacing everything for any fault?
Thanks, I just think JLR see everyone as a cash cow. I went into great detail with the mechanic and he firstly said it was an electrical fault. Now i’m hit with a whole new pump. 🤷🏼‍♀️ I’ve noticed so many owners with the same issues. Interesting to hear you’ve had issues with XC90 though.
 

·
Registered
Dynamic 3 door, 2013, SD4, santorini black with pimento and ebony
Joined
·
520 Posts
Yes, it was the DEM (Diferential electronic module) that failed, its the box that is attached to the haldex and he pump motor plugs in to. Car was 10 years old and had about 120000 miles on. My brothers went well over 200000 with no issues.
 

·
Registered
Joined
·
2 Posts
I have had a new front diff, heldex pump, pump module, 2 abs sensors, alternator, 2 x camers, front springs the list goes on. I feel your pain...
All adds up to a grand total of £8656! Lucky I took out the landrover dealers 5 year warrenty!

It could be just a abs sensor as above. It will show traction reduced for other things so don't presume it's something to do with the diff etc. It has a vary wide range to what it covers



Good luck.
 

·
Registered
Spock - MY20 D180 Evoque R-Dynamic SE Santorini Black Pimp-Wagon!
Joined
·
165 Posts
... unless the dealers are just replacing everything for any fault?
This! They are referred to as "Stealers" for a reason... :mad:

@Speedy Gonzales as your Evoque is out of warranty, steer clear of the main dealers and get it looked at by a good LR indy. If you give us your whereabouts I'm sure someone on here will have a good recommendation for you.
 
1 - 11 of 11 Posts
Top