Evoque Owners Club banner

1 - 20 of 39 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I took delivery of my Evoque coupe Dynamic only three days ago in Istanbul. However I sadly had to return it back to the dealer due a very obvious clonking noise from the front suspension as I went over the speed bumps
. Unfortunately there are many of these in Istanbul. Has anybody had a similar problem? I was told that two other cars sold in Istanbul were returned to the dealers due to the same problem.
 

·
Registered
Joined
·
6 Posts
Hi
Ive seen faulty front struts that have play in them and cause this noise. Get hold of the top of the wheel and try and pull it outwards to see if you can feel play in it.





Pete
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
The dealer changed the front struts under warranty, however, the clonking sound is still there. I was told that all cars had a similar problem and Land Rover UK has been notified. They are looking into it. I wonder if any other Evoque owner in the UK has the same complaint.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Update on the clonking from the front suspension. Unfortunately the problem is still unsolved and is getting worse. I drove an almost brand new Evoque and the car has the same problem. Evidently Land Rover UK claims that the sound is normal and should not be considered a problem. It is however quite bothersome and undermines the quality feel of the car and the solidity of the suspension.
 

·
Registered
Joined
·
79 Posts
Hi
I think I know the 'clonking noise' you talk of, if its the same thing then I would describe it as a bang and was noticable in the Freelander I had on loan when it was driven over large speed bumps at speed. Although it felt like it was happening when the suspension was fully compressed.
 

·
Registered
Joined
·
97 Posts
Its interesting you say that rob.angus. My current car is a Freelander 2 (Evoque due in March hurray!!) and if I go over a speed bump quickly, I get quite a bang on the suspension. I think you are right, it is when the suspension compresses. I have the perfect speed bump on the way to work so will "investigate" tomorrow!To be honest, I never considered it to be a fault as I appreciated I might have gone over the bumps too fast anyway, because as stated, it only appears to make the noise at speed?
 

·
Registered
Joined
·
97 Posts
Well I have conducted my non scientific experiment.I definitely get a loud clunk but only at speed, and to be fair, driving so fast over the speed bump is too much and uncomfortable. At least 20mph.
It appears to be as the front suspension is under compression on top of the bump and it then releasing back to its normal state? I am pretty sure it is nothing to do with the rear suspension.
I don't know if this helps or reassures??
 

·
Registered
Joined
·
23 Posts
Mine did that once over a speed bump in London which I may have gone a teesny bit too quick over - gave me a bit of concern but it hasn't done it since. Mainly because I now go more slowly over speed bumps. ;)
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
I get the sound at any speed over 15 mph. You really have to slow down not to notice it. I definitely think this a problem as none of my cars had it in the past. I hope the company comes up with a solution
 

·
Registered
Joined
·
119 Posts
Perhaps they should add a page in the manual instructing people on what speed bumps are for. They are to slow people down, if you drive over them quickly then perhaps you will get a clanking. Same as if i go over a humpback bridge at 60mph, doesn't say in the manual not to but I think the suspension may go bang if i do it.....
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
Speed bumps I agree. I am not a lunatic that drives fast over speed bumps. However I get the same sound when driving over uneven tarmac. It gives a sense of looseness that hampers the overall perceived quality of the car.
 

·
Registered
Joined
·
1 Posts
Hi All Had to take our Pure sd auto back to dealer today six weeks old 1500 miles, knocking from underneath front, service person says new propshaft salesman new front strut?
 

·
Registered
Joined
·
1 Posts
I have a SD4 dynamic auto with all of the bells and whistles including rear entertainment. I've had it for about a month and so far done 1000 miles in it and i waited a year for it.

There are a few issues with it the main one being that when the car is idling at lights or when stood the revs will hiccup / drop. This happens in all gears and park but is definately more noticeable in drive and reverse.


Also if you are in forward or reverse and you take your foot almost off the brake pedal so that you only just start to move forward / reverse then the car seriously bunny hops which i take to be attributed to the fault above.


The car has been to the dealer twice and they have acknowledged the fault but no errors show on the diagnostics.
They then got Land Rover involved. They came up with their laptops and acknowledged the issue but couldnt find the problem and it has now been taken back to the Land Rover factory for roughly 10 days to see if they can find the issue.


Funny thing is i came on this forum to see if anyone else had experienced the same fault then came across the knocking sound issue from the suspension thread.


I also have this suspension issue. I dont drive over speed bumps fast but when i turn into my drive which is a 90 degree turn there is always one front wheel on the road and the other wheel is up the kerb i get the knocking noise which is really a bit annoying on a £50K car.


The thing is that whilst my car is back at the factory they have given me a evoque petrol dynamic auto.


It has exactly the same knocking noise when turning into the drive !


One other slight issue is on the rear entertainment system sometimes the rear screen will not turn on come hell or high water.


I am disappointed in the car. the fuel economy is worse than my old 2007 freelander.


That said the car is a great headturner just a shame i am having such a bad experience with it.


I think Land Rover definately have a problem on their hands with this car and if the knocking gets worse then i'll let you know.


B Atkins
 

·
Registered
Joined
·
14 Posts
I have exactly the same issue with my suspension. Im beginning to worry. As i am in Cyprus I dont like visitng the LR garage - in fear something else will go wrong! Has anyone has this issue solved? I have just emailed my dealer and hope I get a replying saying "yes we are aware of this suspension issue and we are able to fix it"
 

·
Registered
Joined
·
1 Posts
Land Rover seem to be in denial about this problem. In South Africa the thumping is called a characteristic of the car. Perhaps they don't know the the difference between "fault" and"characteristic"
 

·
Registered
Joined
·
12 Posts
Discussion Starter #16
LR Turkey changed the struts but the problem still persists. Apparently LR UK claims that the problem is characteristic of the car same as what they said in South Africa. I find it quite annoying as the car doesn't feel solid and this hampers the quality perception overall.
 

·
Registered
Joined
·
71 Posts
Hey Burman.

Give your dealer a good talking too, you paid them good money for your car.


Dont be afraid ,they NEED use to come back to them and BUY another car in the futrure.




Z
 

·
Registered
Joined
·
3 Posts
I agree with u i just bought my evoque dynamic petrol 3 days a go...I was so excited after I heard that knocking sound almost all of my fromt n rear..makes me sick..i hate to hear those kind of noises...I ve sold my ML350 just to change into RR...I felt so disappointed
Such a beautiful and luxury n sexy car have that kind of problem...and its not a Cheap car.. in Indonesia car is very expensive..(150 K USD the price over here)
I really do RR have something to fix this as I know lot of people n sell right now in Jakarta all because that issue...its silly and very bad for RR reputation around the world...
 
1 - 20 of 39 Posts
Top