Evoque Owners Club banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello everyone, hope you all well

I am owner of Evoque 2.2 Diesel Automatic 2014, and I had no issues with the car until 2-3 months ago when this car began to have an unresolved problem which make me lose my mind.
While I was driving 40-50 mp per hour, the car suddenly lost 90% of its power, and began to behave as in restricted mode, but there was not even a error on the dash.It was hard to drive because it only goes like 1800 rpm and I had to press the gas just a little otherwise it feels like the car intends to cut out the gas.
I went home and the next day the car was like never had any issue until I ve done like 30 miles and the same problem returned.From that day, it happened every day as sometimes the car run perfect the whole day and sometimes in couple of minutes began to run as in restricted mode but not even one error in the dash.
I went to the dealer there was no error on the computer so they decided to replace the turbo charger.After few days , I got the car back and with the same issue.They admited they were wrong, put my turbocharger back charged me just for the maintenance and the next thing they said is to replace the DPF Catalytic Convertor and the Oxygen Sensor , which cost me a lot of money .Well done they have replaced them , but the car remain with the same issue.So just time and a lot money wasted, and they told me there is nothing they can do anymore .I tried to solve the problem with different garage but they refuses to help me after hearing the story of my car :)

Could anyone give me some advice or maybe someone had the same problem?

Thanks in advance for any suggestion
 

·
Super Moderator
MY14 Jaguar F Type 3.0S Convertible
Joined
·
15,143 Posts
Has the fuel filter been changed recently ?

Could be it needs replaced
 
  • Like
Reactions: Samuel Panainte

·
Administrator
Joined
·
3,389 Posts
Definitely sounds like a fuel supply issue, it's an easy thing to do to get the filter changed again and re-bled. Or find a dealer that has a clue... or better an independent.
 

·
Registered
MY15 2.2L
Joined
·
4,064 Posts
I'm surprised the "dealer" would decide to replace the turbo under your circumstances!?! (and then swap it back...)
Was this a LR main dealer as the labour would have cost a LOT?

Same for the DPF...
How much have you spent so far?

Always a bit of a shame when someone only joins our Owner's Club when they have problems...
 
  • Like
Reactions: Samuel Panainte

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
I'm surprised the "dealer" would decide to replace the turbo under your circumstances!?! (and then swap it back...)
Was this a LR main dealer as the labour would have cost a LOT?

Same for the DPF...
How much have you spent so far?

Always a bit of a shame when someone only joins our Owner's Club when they have problems...
Hello
I ve been part of this group for a while,but without being registred member, even before to buy my range rover, because I was just reading and finding useful information about this car(I owned the jaguar xj before), and yes I decided to create an account an make my first post because of my rr problem, sorry for that .
So, about the dealer , was the main dealer and they decided to replace the turbo, not me, and then they fitted my turbo back.No ideea under what circumstances.They charged labour cost per hour.
DPF cost me a lot arround 2000£ if I m
not wrong , they told me my DPF will not work anymore because they found a lot of sot and it was crashed inside .They suggested me to replace it otherwise “the car could get in fire”.
 

·
Registered
MY2016 Evoque HSE Dynamic 2.0D
Joined
·
346 Posts
Had a similar problem with our old FFRR. It was eventually identified as an intermittent problem with the secondary fuel pump.
 

·
Registered
21MY D165SE in Fuji White with Cloud interior
Joined
·
22 Posts
I also think it is a fuel flow issue, modern diesels work with very high pressure fuel spray and the fuel also acts as a lubricant, so any a minor problem could cause damage to the pump,
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
For anyone facing the problem, the car finally got fixed , after replacing the fuel filter with a genuine Land Rover one.I ve been driving 2 month since then and not a single problem.Thanks a lot for everyone who tried to help , especially the guy who advised me to replace the fuel filter.(The old filter was also almost new).Many thanks
 

·
Registered
Joined
·
5,100 Posts
I reckon it could be the fuel filter, good job you changed it
 

·
Administrator
Joined
·
3,389 Posts
Thanks for letting us know Samuel.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top