Evoque Owners Club banner
1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all,
New to here, so hello to all.
I have a 2017 (67 plate) SE Tech Evoque and it’s recently developed an issue with the SD card for the satnav.
I’ve trawled lots of websites and googled the problem to death, trying all manor of potential fixes from:
Ensuring card is set to write position to reformatting card and reinstalling back up on to it, which appeared to work, I’ve also replaced card, but still get the same issue. I’ve also tried cleaning the actual reader, no joy. As I say I’m a newbie and I’m hoping someone on here may be able to help.

thanks in advance
 

·
Registered
Joined
·
4,794 Posts
Shame you didn't join the club under better circumstances

I might he mistaken but wasn't there a known fault with the card readers of that particular vintage
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Hi Doink,
I’m not sure, it’s really strange as it’s only just started to happen and we’ve had the car for over a year now, typically the warranty has expired too. I could ask Landrover about the known card reader issue?
 

·
Registered
Joined
·
4,794 Posts
Just a few things I remember from some time back, make sure if not already its a decent sd card like a SanDisk, make sure it's set in write mode and if formatting make sure it's FAT32
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
I think I’ve done all of those and a few odd ones too, turn engine off, lock for 2 mins and open and start car again, funnily enough problem still there. Do you think I should ask LR about the known issue, is there a part number that anyone is aware of for the reader?

thanks, any advice on this issue would be appreciated
 

·
Registered
Joined
·
4,794 Posts
LR085516
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
Morning Doink,

not sure if you can help, but back in Apr you mentioned that the might have been a knownfault with the sad card reader on my Evoque. Any ideas on how I find that out, I’ve trawled the internet without success and asked and my local MD and got a flat, can’t see anything on the system response?
Any thoughts
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Hi, I’m having the same issue with the SD card. Were you able to fix the problem?
Thank you!
Hi,
No not fixed yet, I’ve cleaned out the as card reader, Updated sd card without success, for me it’s either a new reader, or it may have something to do with the GPS antenna at the back, either way probably means a visit to the garage and likely a hefty bill too
 

·
Registered
2019 Range Rover Evoque
Joined
·
2 Posts
Hi,
No not fixed yet, I’ve cleaned out the as card reader, Updated sd card without success, for me it’s either a new reader, or it may have something to do with the GPS antenna at the back, either way probably means a visit to the garage and likely a hefty bill too
Thank you so much for responding! I was afraid you would say it needs to be taken to the garage! No doubt it will cost a fortune to fix.
Thanks again for your help and good luck!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Thank you so much for responding! I was afraid you would say it needs to be taken to the garage! No doubt it will cost a fortune to fix.
Thanks again for your help and good luck!
No worries, I’ll keep you posted on what they say, but I might have to wait until July to get a booking. Hope yours goes well
 
1 - 12 of 12 Posts
Top