Evoque Owners Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

I've had my new Evoque for about 4 weeks (R Dynamic S Eigar Grey) it's a brilliant car and a big upgrade on our previous Evoque.

One thing I'm noticing often is the Pivi Pro on the main screen will often reset/reboot mid journey. Has anyone else had this happen? It's had a software update recently but it seems to do it on most journeys and not helpful when needing the sat nav on.

Is it worth a call into land rover?
Cheers
 

·
Registered
2021 P200 R-Design S Fuji
Joined
·
214 Posts
For sure it is not a feature of Pivi Pro. I seem to recall something similar being reported previously but not recently. You could try rebooting Pivi by holding down the volume button below the upper touchscreen for 20 secs, which has resolved a few issues for others. Otherwise, yes a call to the dealer.
 
  • Like
Reactions: Lh85

·
Registered
R-Dynamic SE P300e Firenze Red/Pan Roof/Black Pack
Joined
·
322 Posts
This happened on mine at the start of ownership and went on for sometime. Screens (top and bottom) going blank Complete loss of all maps on sat nav. No voice response or audio, no USB or Android auto. Unable to set up a profile and then when able it would be deleted after a couple of journeys. All random. Seems to have settled down recently after a number of updates.I didn't take it to the dealership However my car has developed more serious issues as I've documented. Welcome to Evoque ownership 😭
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks FB1, hopefully it's something that sorts itself out with updates. I've had my fair share of issues with my old Evoque 17 SE Tech (DPF, door latches, electrics etc) I said never again but couldn't say no to the new one :D
 
1 - 4 of 4 Posts
Top