Evoque Owners Club banner
1 - 7 of 7 Posts

·
Registered
MY21 P300e SE, priv glass, pano roof, wool interior, black pack...
Joined
·
45 Posts
Discussion Starter · #1 ·
I took delivery of my Evoque on March first, and initially was over the moon with the car - it's without doubt a premium place to sit and I enjoy the driving experience, that being said I have had a number of issues, some seem to be ongoing and I'd like to know if it's just my car or actually how they're intended to operate - as listed the car is a hybrid, for the first ~2 months of owning the car I was commuting daily using exclusively electrical power (my commute is approx 22 miles total, should be ideal even in poor weather), however following an "over the air update" a few months ago the car will refuse to use the battery without running the engine for a few miles first, when pressing the EV button I get a message to say "EV is temporarily unavailable", sometimes it does accept the mode change but doesn't shift onto electrical power... this is ruining the economy of the car, as previously I had an average of 130mpg (over the life of the car). Additionally it's been back to LR twice for an engine warning light (no noticeable affects of the light on performance of the car), and recently it's now got an intermittent warning light... it's genuinely frustrating me, does any other hybrid owners see this or does your car run on battery if available?
 

·
Registered
P300e R Dynamic HSE, Fuji White, Pano Roof, 20" Alloys
Joined
·
65 Posts
Hi

I also pick my P300e up at the beginning of march. What you describing is pretty much the same what I'm getting.

The car was amazing when I first collected, my commute is around 10miles a day, and it would do this all in EV mode, this with free charging at work!

As you say after a few OTA updates this has taken a turn for the worse. Very disappointed, I was basically driving everywhere in EV mode Monday to Friday, then maybe using the ICE a little over the weekend

Don't think it's gonna get any better either!
 

·
Registered
P300e R-Dynamic HSE MY20.5 Firenze red Sliding sun roof
Joined
·
13 Posts
Hi

I also pick my P300e up at the beginning of march. What you describing is pretty much the same what I'm getting.

The car was amazing when I first collected, my commute is around 10miles a day, and it would do this all in EV mode, this with free charging at work!

As you say after a few OTA updates this has taken a turn for the worse. Very disappointed, I was basically driving everywhere in EV mode Monday to Friday, then maybe using the ICE a little over the weekend

Don't think it's gonna get any better either!
Are you sure these are both MY21 vehicles? Mine was registered in May 21 and is MY20.5. With your experiences I’m very reluctant to accept any updates as it’s running as both of yours did initially.
 

·
Registered
Joined
·
91 Posts
Mine is a MY 20.5 and my experience is exactly the same. It refuses to start in EV mode now ….. it didn’t when I first got it ….. but several updates later and it now always starts on ICE , even when EV mode is selected . Eventually , the ICE knocks off and EV takes over and it operates as it should . But it’s very frustrating ( as has the whole ownership experience tbh ). It should be a great car to own - but it’s very quirky with its silly electrical gremlins and messages , it operates in whatever mode it feels like , and the dealership customer service is terrible…… it’s almost like a shrug and “ oh well , what did you expect ?, you bought a land rover !”
 

·
Registered
P300e R Dynamic HSE, Fuji White, Pano Roof, 20" Alloys
Joined
·
65 Posts
Mine is a MY 20.5 and my experience is exactly the same. It refuses to start in EV mode now ….. it didn’t when I first got it ….. but several updates later and it now always starts on ICE , even when EV mode is selected . Eventually , the ICE knocks off and EV takes over and it operates as it should . But it’s very frustrating ( as has the whole ownership experience tbh ). It should be a great car to own - but it’s very quirky with its silly electrical gremlins and messages , it operates in whatever mode it feels like , and the dealership customer service is terrible…… it’s almost like a shrug and “ oh well , what did you expect ?, you bought a land rover !”
Exactly same response I got from dealership, mine has been in for a new EV motor too, all sorts of problem, car saying "special programs not available" so would disable the EV motor, lane assist, cruise control, parking sensors, cameras, electric handbrake to name a few.

Dealership said work carried out came to 10K, ouch! Range Rover HQ kept my car for testing for 3 days as it seems like it's a big problem, but they don't what's causing it.

Its a real shame because the car is amazing when working, just think RR have realised allowing the car to run in EV mode all the time isn't going to be any good for the ICE, so are taking the decision to force the ICE engine to start in certain circumstances which is fine if your commute is 20 mile and you do the first 2 mile using the ICE. But when your commute is 4 mile, the ratio is not sure good!
 

·
Registered
MY21 P300e SE, priv glass, pano roof, wool interior, black pack...
Joined
·
45 Posts
Discussion Starter · #6 ·
Exactly same response I got from dealership, mine has been in for a new EV motor too, all sorts of problem, car saying "special programs not available" so would disable the EV motor, lane assist, cruise control, parking sensors, cameras, electric handbrake to name a few.

Dealership said work carried out came to 10K, ouch! Range Rover HQ kept my car for testing for 3 days as it seems like it's a big problem, but they don't what's causing it.

Its a real shame because the car is amazing when working, just think RR have realised allowing the car to run in EV mode all the time isn't going to be any good for the ICE, so are taking the decision to force the ICE engine to start in certain circumstances which is fine if your commute is 20 mile and you do the first 2 mile using the ICE. But when your commute is 4 mile, the ratio is not sure good!
If it is because of that it should say so on the display, at least we'd know what was going on.
 

·
Registered
MY21 P300e SE, priv glass, pano roof, wool interior, black pack...
Joined
·
45 Posts
Discussion Starter · #7 ·
Are you sure these are both MY21 vehicles? Mine was registered in May 21 and is MY20.5. With your experiences I’m very reluctant to accept any updates as it’s running as both of yours did initially.
Mine is a MY21, but I don't think much changed between 20.5 and 21 for the engine and driveline system, it seems the main difference was Pivi Pro and a new steering wheel 🤷🏻‍♂️
 
  • Like
Reactions: DavidA
1 - 7 of 7 Posts
Top