Evoque Owners Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Based on several reports on other JLR forums, it is clear that the new Pivi Pro software is full of bugs and responsible for several problems (Profile loss, Sat Nav issues etc).
This applies to other models equipped with Pivi Pro (Velar, Discovery, F-Pace).

I am starting this thread to discuss a particular problem and see how many others have been affected.

After 5-10 minutes of driving, the audio starts to crackle. Almost unnoticeable in the beginning, but constantly increasing until the system only plays loud static from the speakers.

Nothing changes if you turn on/off, lock/unlock or even reset Pivi Pro. It returns to normal if you leave the car unused for many hours.

Right now, I can only listen to music (any source) or use hands free calling for the first 5-10 minutes of driving. After that, minor crackling kicks in and gets worse and worse, forcing you to turn off the volume completely. Both annoying and dangerous.

After 2 months, several visits to the dealership and an amplifier replacement, the problem remains. Latest update from JLR: "We have to wait for the new software update, scheduled for release by the end of June".

To be honest, this does not look like a typical pattern of a software bug.
It lacks consistency and is affected by the car's running time. I am very curious about how a software bug magically disappears after 3-4 hours of the car engine being idle and reappears after 5-10 minutes of driving.

I have been in contact with another user of this forum that has the same problem (on a Discovery). Just wanted to gather other occurrences of the same problem in a dedicated thread, before deciding on next steps and possible rejection of the car.
 

·
Registered
Joined
·
1 Posts
Hi Makis, same here on Discover Sport MY 2021 in Italy. Just pickup up yesterday from dealer check and they just run a SW update. To me sounds not related to a bug too but I was sure to be the amplifier...Up to today I was not able to check really if it was solving since I heard some small crackling after the pickup but no time to drive for some time (to me was getting worse after about 30 mins of driving...Dealer claiming JLR is checking it but they don't know what to do...What is scaring me is that I was sure it was the amplifier (some bad soldering or something about components getting hot) but now I read that for you was not working....

Carlo
 

·
Registered
Joined
·
4 Posts
Hi Makis, same here on Discover Sport MY 2021 in Italy. Just pickup up yesterday from dealer check and they just run a SW update. To me sounds not related to a bug too but I was sure to be the amplifier...Up to today I was not able to check really if it was solving since I heard some small crackling after the pickup but no time to drive for some time (to me was getting worse after about 30 mins of driving...Dealer claiming JLR is checking it but they don't know what to do...What is scaring me is that I was sure it was the amplifier (some bad soldering or something about components getting hot) but now I read that for you was not working....

Carlo
identical problem on DS my 2021, I too have talked about a software update, for July, maybe ....... thank the creator of this discussion for raising the question .......
have you been able to check if the update they made has solved the problem?
Mauro
 

·
Registered
MY15 2.2L
Joined
·
2,945 Posts
I've read too many forum posts...

In the week I could hear a strange noise from low down. Didn't think too much about it as I was on a short journey. It was still there on my next trip, seemed to be in-sync with the music?! Started to panic about failing sound module, dodgy wiring, software, etc. etc. Then reached down into the door pocket and found my plastic ice scraper was at a different angle and vibrating off the speaker!
Panic over :)
 
  • Like
Reactions: Col_C and PPB

·
Registered
Joined
·
1 Posts
I’m also having the same problem on my Discovery Sport MY21 - it’s driving me insane. I’m booked into my local JLR dealer next week. If your experiences are anything to go by, I’m not hopeful. Does anyone know what my rights are regarding rejecting the car based on an issue like this?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I’m also having the same problem on my Discovery Sport MY21 - it’s driving me insane. I’m booked into my local JLR dealer next week. If your experiences are anything to go by, I’m not hopeful. Does anyone know what my rights are regarding rejecting the car based on an issue like this?
I have decided to give them a chance and wait a few more days for the software update. If this doesn't fix it, I will demand a Pivi Pro replacement. Haven't yet considered rejection options to be honest; the dealer is determined to find a solution to this. I hope to have this sorted by the end of June.
 
1 - 6 of 6 Posts
Top