Evoque Owners Club banner

1 - 11 of 11 Posts

Registered
MY20.5 Range Rover Evoque (L551) First Edition P250 in Nolita Grey on a 70 plate
Joined
685 Posts
Discussion Starter #1 (Edited)
I'm certain when I first got my new 2020.5MY Evoque that when I was nearing a speed camera (shown correctly on the navigation map) it would alert me by means of a sound, regardless of whether I was using the navigation for a route or not.

Alerts are definitely switched on, but of late it does nothing when I pass a camera. I'm not sure if its disappeared after a map update or with the car having a long period out of use.

I have tried to set the navigation to make sure the voice sound was turned up loud and it is.

I've even done a full factory reset of the ICTP system, but still no alerts whilst driving.

Today I have found that if I set a navigation route, when nearing the camera on that route, it will alert, but otherwise nothing.

Does anyone else with the ICTP Duo have it doing any different from this. I know there have been some posts about the Pivi system, but I'd just be interested to know.
 

Registered
Joined
2,412 Posts
Had the ICTP duo on my Velar where everything worked fine regardless whether you were in nav mode or not. Nice loud audible warning and even had average speed camera warning after software update this time last year. So now I'm royally pis#ed off that the new all singing all dancing Pivi Pro system is a crock when it comes to "safety " camera warnings. Looks like a trip to the dealers but I ain't holding my breath馃槨
 
  • Like
Reactions: Whoever and rencar

Registered
Joined
1,429 Posts
Mine are working fine (checked today) on my ICTPro but I haven't done my maps for several months.
Just wondering if a recent map update has knackered the alerts?
 
  • Like
Reactions: rencar

Registered
MY20.5 Range Rover Evoque (L551) First Edition P250 in Nolita Grey on a 70 plate
Joined
685 Posts
Discussion Starter #4
Thanks for the replies so far.

It would be great to hear from some other ICTP Duo (MY2019/2020) owners if they have noticed the alerts have stopped after a recent map update. I can鈥檛 fathom how to get them back and operational again. Real nuisance.

Yoda - I can fully understand your frustration especially with the new Pivi Pro system that seems to still be a 鈥榳ork in progress鈥, whilst you and new MY2021 owners kindly test it out for JLR!
 
  • Like
Reactions: Yoda

Registered
Joined
3,035 Posts
I鈥檝e (literally) just returned from a 140 mile round trip. I did the latest update a couple of days ago.
I was using the Nav in both directions & I got audible warnings for every camera I passed. I can鈥檛 comment on whether it鈥檚 sounding alerts without a route planned as I haven鈥檛 been anywhere since the update until this mornings trip.
 
  • Like
Reactions: rencar

Registered
MY20 P300 HSE R-Dynamic
Joined
62 Posts
I seem to recall on my recent 300 mile trip to Essex it only beeps and shows info if a route is programmed. Would like it to have a better sound than just a single beep. I updated my maps about 2 weeks ago. Also warnings if not on the nav screen.
 

Registered
MY20.5 Range Rover Evoque (L551) First Edition P250 in Nolita Grey on a 70 plate
Joined
685 Posts
Discussion Starter #7
Thanks Guys for your help (such a great forum) - When I set a route using the navigation on my car, it does seem I get alerts just before the camera. I see the various symbols showing the cameras on the map.

However is anyone able to confirm for me that when just driving (without any route set - say listening to the radio) that they do or don't receive safety camera alerts as they approach on your ICTP Duo system?
 

Registered
Joined
145 Posts
I don鈥檛 seem to.
 
  • Like
Reactions: rencar

Registered
EVOQUE 2020 1st Edition
Joined
11 Posts
Thanks for the replies so far.

It would be great to hear from some other ICTP Duo (MY2019/2020) owners if they have noticed the alerts have stopped after a recent map update. I can鈥檛 fathom how to get them back and operational again. Real nuisance.

Yoda - I can fully understand your frustration especially with the new Pivi Pro system that seems to still be a 鈥榳ork in progress鈥, whilst you and new MY2021 owners kindly test it out for JLR!
My speed camera alerts have stopped unless I have a route set. My last map update was probably Jan.
 

Registered
MY20.5 Range Rover Evoque (L551) First Edition P250 in Nolita Grey on a 70 plate
Joined
685 Posts
Discussion Starter #11
Thanks a lot. I am almost 100% certain that when I got my car and for the last few months it was alerting when simply using the radio and driving near a safety camera (ie. without a navigation route being set).

I reckon one of the last few monthly map updates I鈥檝e done (I do them each month - perhaps I shouldn鈥檛 have bothered), has stopped this useful feature working.
 
1 - 11 of 11 Posts
Top