Evoque Owners Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

I am living in switzerland and have a Evoque, amazing car and the only issue we have is our front HB3 bulbs keep on blowing. In the last 4 months we have gone though 5 bulbs. We only drive on swiss roads and I was wondering if anyone else has had this problem? Does anyone have any advice on what to do? If not I will take it to a garage but the cost over here for that is stupid so any advice would be amazing. Thank you so much.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
that was my feeling but i was wondering if others have had this issue..... thanks so much for your reply. have a great evening
 

·
Super Moderator
Joined
·
7,323 Posts
Haven't heard this on OEM bulbs but have heard of people replacing bulbs with non OEM and not getting much life out of them based on incorrect fitting or inferior bulb.
Search the forum as this was discussed just before Christmas I think ......
 

·
Registered
Joined
·
104 Posts
yes I have this often but I did go through a phase of using the brighter whiter bulbs from halfords I recently changed them to Bosch bulbs so will see what happens
 

·
Registered
Joined
·
1 Posts
Late to the discussion but I had this problem for almost a year. I always have upgraded my bulbs for more brightness at night, however, a quick chat with a land rover mechanic informed me that the Evoque cant cope with the extra load from non OEM bulbs causing them to literally swell and explode. I tried many brands, including bosch. Either stick with OEM, do a mayjor wiring overhaul or buy the facelift model with LEDs was the outcome
 
1 - 6 of 6 Posts
Top